Gekko 0.6 released
#71
Quote:I'm using Chrome on a mac. UI (still) works on an older version of Gekko.

Could you please open an issue on github with more debug information?

Quote:Error: General:Temporary lockout
at rawRequest (/var/www/nodejs/gekko06/exchange/node_modules/kraken-api/kraken.js:54:9)
at <anonymous>

Very strange, never seen that before. Fixed it now here: https://github.com/askmike/gekko/commit/...f5106471eb

Quote:2018-08-17 10:00:58 (INFO): Received advice to sell however Gekko is already in the process to undefined

Can you open an issue on github with full logs?
  Reply
#72
[quote pid='60023' dateline='1534738059']
Quote:Error: General:Temporary lockout
at rawRequest (/var/www/nodejs/gekko06/exchange/node_modules/kraken-api/kraken.js:54:9)
at <anonymous>

Very strange, never seen that before. Fixed it now here: https://github.com/askmike/gekko/commit/...f5106471eb



Hi Mike, thx for addressing this by adding it to the recoverable errors. It seems the "temporary lockout" is caused by private api calls/syncing. I found this:

https://support.kraken.com/hc/en-us/arti...rate-limit-

According kraken support it probably gets locked out for 15 minutes. How often is the balance checked during a sticky order? Maybe with many "moving orders" the api limit is hit? This would explain why kraken is executing the order sometimes and sometimes not...I remember from code that the sticky order is acting on 1.5sec intervals. Maybe put this param into config so we can increase it to 5 sec for kraken?

[/quote]
  Reply
#73
Quote:According kraken support it probably gets locked out for 15 minutes. How often is the balance checked during a sticky order? Maybe with many "moving orders" the api limit is hit?

I see, usually these types of errors are called rate limits. Gekko doesn't check balance very often but it does check the order every second. I will increase this timer.
  Reply
#74
(07-22-2018, 12:25 AM)wewantmoore Wrote:
(07-22-2018, 12:19 AM)askmike Wrote:
(07-22-2018, 12:00 AM)wewantmoore Wrote: I still can't get the UI working. Gekko 6.3 will work in CLI but if I run the UI I keep getting a blank page.

What browser are you using? Currently I am only sure Gekko works in latest firefox or chrome.


I'm using Chrome on a mac. UI (still) works on an older version of Gekko.

I am still having this problem. I just continued to work with an older version of gekko, but want to switch over to the new version eventually.. What could it be? UI still works on an older version, doesn't work with a completely new install of 0.6.6..

EDIT: Javascript console on chrome gives me:

app.f8381cdf.js:1 Uncaught SyntaxError: Unexpected token ...
  Reply
#75
Quote:app.f8381cdf.js:1 Uncaught SyntaxError: Unexpected token ...


What version of Chrome are you running? Make sure it's recent.
  Reply
#76
(09-06-2018, 04:22 AM)askmike Wrote:
Quote:app.f8381cdf.js:1 Uncaught SyntaxError: Unexpected token ...


What version of Chrome are you running? Make sure it's recent.

Great. That works.. Thanks
  Reply


Forum Jump:


Users browsing this thread: