Cannot find module '../core/log.js
So I was lazy and just installed Gekko as root, so that might be a potential cause of all my issues, if not then there's a bigger problem.

I'm getting the error "Cannot find module '../core/log.js" from some strategies. even though that file definitely exists on the correct relative path as I have manually tested.

I'm also getting various errors like RSI indicator not found, even though it definitely is in the indicators folder.

Anyone have any idea what's going wrong? Of course first thing I will do is try a full re-install as non-root user but it would be nice to know what went wrong. Thanks.

I'm also trying to get tommiehansen's 'simple bull/bear' RSI strategy working, hence I was also getting the errors on that, as well as when trying to run RSI or StockRSI on the backtester.
Turns out the RSI 'strategy' file somehow ended up in the indicators directory. I'm going to slowly go through and fix the locations of these files, if i fail I will just delete everything in strategies and indicators and redump from the Github.

I will post again upon fixing these issues so that it can help anyone else who did the same stupid thing as me.
Fixed the original errors, but I still get 'ERROR: Tulip indicators is not enabled' and probably same for the Talib ones even though both are installed.

Think it may be that I need to reinstall them and add '--production' on the installation line, that is what i am trying next.
Progress so far:

I am able to run the standard RSI_BULL_BEAR strategy without errors, but it does not show me any PNL table from the output.

When I run the RSI_BULL_BEAR_ADX strategy I get the error - 'uncaughtException TypeError: Cannot read property 'long' of undefined'

Forum Jump:

Users browsing this thread: