SQLITE_CORRUPT error
#1
Question 
I had Gekko running for awhile on my Win 10 Pro machine, but am now receiving the error, "{ Error: SQLITE_CORRUPT: database disk image is malformed errno: 11, code: 'SQLITE_CORRUPT' }", when I try to "Scan available data" in the Gekko UI.

Can someone help me with the Bash commands to uninstall the DB and start all over?

I have already tried to uninstall Ubuntu (which I downloaded from the Windows store) and reinstall it, but that did not fix the issue.

Any other advice to get it up and running again on my Win 10 Pro box would be helpful. Thanks.


Attached Files
.jpg   SQLITE Error in Ubuntu for Gekko.JPG (Size: 89.35 KB / Downloads: 4)
Best regards,
Christopher Bradley
  Reply
#2
(01-04-2019, 06:08 PM)chrisb647100 Wrote: I had Gekko running for awhile on my Win 10 Pro machine, but am now receiving the error, "{ Error: SQLITE_CORRUPT: database disk image is malformed errno: 11, code: 'SQLITE_CORRUPT' }", when I try to "Scan available data" in the Gekko UI.

Can someone help me with the Bash commands to uninstall the DB and start all over?

I have already tried to uninstall Ubuntu (which I downloaded from the Windows store) and reinstall it, but that did not fix the issue.

Any other advice to get it up and running again on my Win 10 Pro box would be helpful. Thanks.

**UPDATE - I navigated to "C:\Users\Christopher Bradley\AppData\Local\Packages\CanonicalGroupLimited.UbuntuonWindows_79rhkp1fndgsc\LocalState\rootfs\home\chrisb", and appended the folder names, "gekko", ".node-gyp", and ".npm" with ".old", then ran through the entire installation process from start to finish.

The installation seems to be functioning properly again.
Best regards,
Christopher Bradley
  Reply
#3
(01-05-2019, 12:56 PM)chrisb647100 Wrote:
(01-04-2019, 06:08 PM)chrisb647100 Wrote: I had Gekko running for awhile on my Win 10 Pro machine, but am now receiving the error, "{ Error: SQLITE_CORRUPT: database disk image is malformed errno: 11, code: 'SQLITE_CORRUPT' }", when I try to "Scan available data" in the Gekko UI.

Can someone help me with the Bash commands to uninstall the DB and start all over?

I have already tried to uninstall Ubuntu (which I downloaded from the Windows store) and reinstall it, but that did not fix the issue.

Any other advice to get it up and running again on my Win 10 Pro box would be helpful. Thanks.

**UPDATE - I navigated to "C:\Users\Christopher Bradley\AppData\Local\Packages\CanonicalGroupLimited.UbuntuonWindows_79rhkp1fndgsc\LocalState\rootfs\home\chrisb", and appended the folder names, "gekko", ".node-gyp", and ".npm" with ".old", then ran through the entire installation process from start to finish.

The installation seems to be functioning properly again.

New **UPDATE - The problem keeps recurring after functioning well for a few minutes. Any help would actually be appreciated after all.

I am running a Windows 10 Pro machine with Bash enabled and have Ubuntu installed from the Microsoft store. I am attempting to run Gekko following the instructions for Win 10 with Bash. Everything seems to function fine for awhile and then I get the error, attached. Does anyone know what might be happening to corrupt the DB. My feeling is that I am running something incompatible. IDK. Thanks!


.jpg   Gekko SQLITE Error on Get.JPG (Size: 110.13 KB / Downloads: 1)
Best regards,
Christopher Bradley
  Reply
#4
Simply install it on ubuntu in virtualbox and you can avoid a lot of problems.On windows it is a pain to operate it.
  Reply
#5
Thanks for the wake up call! I keep dreaming of that day when Microsoft gets it right. Deep down inside, I know that they never will...
Best regards,
Christopher Bradley
  Reply


Forum Jump:


Users browsing this thread: