DustinJSilk/reactive-trader
#1
Hi
Has enyone tested the DustinJSilk/reactive-trader yet?

This sounds very promising to me.

See my thread about: Gekko-GeneticAlgorithm From Gekko Warez
grz.philipp
  Reply
#2
Hi,
Unfortunately i couldn't make it work. The same with Gekkowarez.
Then i found this: https://github.com/Gab0/japonicus
  Reply
#3
Nobody can help if you dont paste log or something else.
  Reply
#4
(02-09-2018, 12:38 PM)Nima Wrote: Hi,
Unfortunately i couldn't make it work. The same with Gekkowarez.
Then i found this: https://github.com/Gab0/japonicus

With problems (mainly unsupporting python3.6) but im runing this. Big Grin On ubuntu 16.* and Mint this will be helpful: https://stackoverflow.com/a/44612200/9267718
Code:
python3.6 japonicus.py -g -r
GEKKO
     ██╗ █████╗ ██████╗  ██████╗ ███╗   ██╗██╗ ██████╗██╗   ██╗███████╗
     ██║██╔══██╗██╔══██╗██╔═══██╗████╗  ██║██║██╔════╝██║   ██║██╔════╝
     ██║███████║██████╔╝██║   ██║██╔██╗ ██║██║██║     ██║   ██║███████╗
██   ██║██╔══██║██╔═══╝ ██║   ██║██║╚██╗██║██║██║     ██║   ██║╚════██║
╚█████╔╝██║  ██║██║     ╚██████╔╝██║ ╚████║██║╚██████╗╚██████╔╝███████║
 ╚════╝ ╚═╝  ╚═╝╚═╝      ╚═════╝ ╚═╝  ╚═══╝╚═╝ ╚═════╝ ╚═════╝ ╚══════╝
v0.29

The profits reported here are the profit beyond market price change;
i.e. shown profit =  <backtest profit> - <market profit in evaluated candlestick period>;
> RSI
Evolving RSI strategy;

evaluated parameters ranges:
interval                      (7, 21)
thresholds.low                (15, 45)
thresholds.high               (45, 140)
thresholds.persistence        (4, 10)

using candlestick dataset 2017-12-18 05:10:00 to 2018-02-09 19:16:00

======  EPOCH 0/400  ======
Locale1
first unevaluated: 30
0 individues removed due to equality
[30]
Mint 18.3 x64
Linux SAMASUNG 4.13.0-26-generic #29~16.04.2-Ubuntu SMP Tue Jan 9 22:00:44 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux
  Reply
#5
it is not related to the topic but Japonicus is working great for me. It works with bayes and genetic Alg.

try this with [3.6] to install Python3 https://stackoverflow.com/questions/3839...ia-apt-get

I tried also DustinJSilk/reactive-trader (waiting for Plugin) and gekkowarez but could not make them run.
using: bash on win10
  Reply
#6
You paste link to installing python3.5 Smile Japonicus requirement 3.6
  Reply
#7
(02-09-2018, 11:22 PM)xFFFFF Wrote: You paste link to installing python3.5 Smile Japonicus requirement 3.6

just replace 3.5 with 3.6 Smile
  Reply


Forum Jump:


Users browsing this thread: