Error talib install on ubuntu
I'm trying to install the talib in node with the instruction:
npm install talib

But after compiling sources it fails with the error:
gyp ERR! configure error
gyp ERR! stack Error: EACCES: permission denied, mkdir '/home/ivan/gekko/gekko/node_modules/talib/build'
gyp ERR! System Linux 4.15.0-20-generic
gyp ERR! command "/usr/bin/node" "/usr/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "configure"
gyp ERR! cwd /home/ivan/gekko/gekko/node_modules/talib
gyp ERR! node -v v8.11.3
gyp ERR! node-gyp -v v3.6.2
gyp ERR! not ok
npm ERR! errno 1
npm ERR! talib@1.0.5 install: 
node ./src/lib/build.js && node-gyp configure && node-gyp build
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the talib@1.0.5 install script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:

I tried it with sudo user with the same result, and changing the permission of the directory to 777, but nothing works, any idea?

Try following my install steps in the video located at this thread ...

Be aware I have condensed the commands compared to what is in the installation video but the new version is in the description and also the comments of the thread I pasted the link to from above.

My guess is that you might be missing the build essential commands section ...
HI TCMabe,

I had the build-essential package, but I did a new fresh installation following your instructions and now its working.

I Think that may be the node version, because it is the unique package that was updated.

Thank you very much!

Forum Jump:

Users browsing this thread: