Amazon Web Server and Gekko Trading Bot Install
#11
The git command section of that process should have downloaded the latest install package from gekko into a folder called gekko. Maybe something has changed... I’ll do some more research and get back to you... you could try starting out with the instructions manually from the website and see if anything from that process gets you started.

I will let you know as soon as I can sort it out ... hopefully later today.
  Reply
#12
TCMabe, thank you again! I finally got it all up and running. A main problem was that I kept getting timed out, so I changed "git clone git://" to "git clone https://", which gave me a secure connection and a successful install. So now, on to the real work and setting up some strategies. Your help has been tremendously valuable!
  Reply
#13
(09-24-2018, 10:54 AM)TCMabe Wrote:
(09-24-2018, 10:17 AM)CryptoCoeus Wrote: Great video,

I followed your instructions except modifying the file at "/etc/nginx/sites-enabled/default"..

I am able to see "Serving Gekko UI on http://50.15.225.155:3000/" on the console.. But, when i go that link browser shows that :

This site can’t be reached
50.15.225.155 refused to connect.
Search Google for 223 150 3000
ERR_CONNECTION_REFUSED

However, 50.15.225.155 shows "Welcome to nginx!" message..

So, I believe I should modify the file at "/etc/nginx/sites-enabled/default" .. Can you please guide me how ? Or this error does not related with modifying that file ?

I am glad you found the tutorial helpful.

I would recommend following the instructions here : https://gekko.wizb.it/docs/installation/...erse-proxy

You should be able to refer to the video and the documentation to sort it out ... I can log in to my server later and see what my settings were, but from memory I believe I replaced my default info with what was in the documentation. Hope this helps !

Cheers !

TC Mabe

I came across this same problem, also replaced the my default what was in the documentation you mentioned in the video. I can go to the NGIX page, but I cant reach my gekko UI. Have you found any other fix to that?
Thanks!
  Reply
#14
Check your inbound and outbound port settings on the server. Refer to the video starting at section 3:05 https://www.youtube.com/watch?v=oary-rQITT0&t=1433s

Hopefully this gets you sorted out.

Good luck !
  Reply
#15
Great video! One more tip: you have to open port 9418 for outgoing connections. Otherwise git will hang when called by npm.
  Reply
#16
Thanks for that tip ... that might be one of the issues that a few installers faced.
If you did not already post that comment on the video page, I will go and add it later. Might save someone a little trouble. Thanks again ! And good luck!
  Reply


Forum Jump:


Users browsing this thread: