[SHARE] GAB - Gekko Automated Backtests
(11-16-2018, 02:48 AM)gekko2yuno Wrote:
(04-14-2018, 08:12 PM)gekko2yuno Wrote:
(04-14-2018, 04:46 PM)tommiehansen Wrote: Major update

MySQL (InnoDB) is now an option that can be used instead of SQLite and code has been re-written to use this, if set, wherever possible.

Why? Because if running massive runs with 10+ threads etc SQLite simply is too prone to errors (and corruption) and isn't a great choice for say 30-100 000+  runs, something that is quite feasible when running 10+ threads and date ranges that span just 3-4 months.

So this became somewhat of a problem and has been solved by letting the user choose MySQL as the database.
Requires the user to set this up in its user.config.php (see new sample.config.php).

Using MySQL is also now the recommended way to run Gabby if you aren't just testing things out.

---

This also introduces a breaking change -- the naming scheme for the database names (SQLite as well) has changed.
This mean that any old runs/database you have for SQLite will now not show up at all since GAB will not recognize these as valid databases (or it will error out).

To solve this use the included tool Compatibility Fix. Currently this will rename your SQLite databases to the new naming scheme automatically.
You'll find it under <your install directory>/tools e.g. localhost:80/gab/tools

to update do:
git pull

or to install the new version to an entirely different dir create a new one and do:
git pull https://github.com/tommiehansen/gab.git

The database name is not required in     Example for mysql: '127.0.0.1:3306,TommieHansenIsTheBest,MySuperPassword' ?
I am getting error:

MySQL db connection test
FAIL Could not connect to MySQL database, error message:
SQLSTATE[HY000] [2002] php_network_getaddresses: getaddrinfo failed: No address associated with hostname

This more have to do with your settings for your database server (and PHP) so you should Google/look into such a problem.
  Reply
(11-16-2018, 04:07 PM)tommiehansen Wrote:
(11-16-2018, 02:48 AM)gekko2yuno Wrote:
(04-14-2018, 08:12 PM)gekko2yuno Wrote:
(04-14-2018, 04:46 PM)tommiehansen Wrote: Major update

MySQL (InnoDB) is now an option that can be used instead of SQLite and code has been re-written to use this, if set, wherever possible.

Why? Because if running massive runs with 10+ threads etc SQLite simply is too prone to errors (and corruption) and isn't a great choice for say 30-100 000+  runs, something that is quite feasible when running 10+ threads and date ranges that span just 3-4 months.

So this became somewhat of a problem and has been solved by letting the user choose MySQL as the database.
Requires the user to set this up in its user.config.php (see new sample.config.php).

Using MySQL is also now the recommended way to run Gabby if you aren't just testing things out.

---

This also introduces a breaking change -- the naming scheme for the database names (SQLite as well) has changed.
This mean that any old runs/database you have for SQLite will now not show up at all since GAB will not recognize these as valid databases (or it will error out).

To solve this use the included tool Compatibility Fix. Currently this will rename your SQLite databases to the new naming scheme automatically.
You'll find it under <your install directory>/tools e.g. localhost:80/gab/tools

to update do:
git pull

or to install the new version to an entirely different dir create a new one and do:
git pull https://github.com/tommiehansen/gab.git

The database name is not required in     Example for mysql: '127.0.0.1:3306,TommieHansenIsTheBest,MySuperPassword' ?
I am getting error:

MySQL db connection test
FAIL Could not connect to MySQL database, error message:
SQLSTATE[HY000] [2002] php_network_getaddresses: getaddrinfo failed: No address associated with hostname

This more have to do with your settings for your database server (and PHP) so you should Google/look into such a problem.

I did but there was no definite solution for it that I understand. Can I have a single database with all the pairs in it itself?
  Reply
(11-16-2018, 09:37 PM)gekko2yuno Wrote:
(11-16-2018, 04:07 PM)tommiehansen Wrote:
(11-16-2018, 02:48 AM)gekko2yuno Wrote:
(04-14-2018, 08:12 PM)gekko2yuno Wrote:
(04-14-2018, 04:46 PM)tommiehansen Wrote: Major update

MySQL (InnoDB) is now an option that can be used instead of SQLite and code has been re-written to use this, if set, wherever possible.

Why? Because if running massive runs with 10+ threads etc SQLite simply is too prone to errors (and corruption) and isn't a great choice for say 30-100 000+  runs, something that is quite feasible when running 10+ threads and date ranges that span just 3-4 months.

So this became somewhat of a problem and has been solved by letting the user choose MySQL as the database.
Requires the user to set this up in its user.config.php (see new sample.config.php).

Using MySQL is also now the recommended way to run Gabby if you aren't just testing things out.

---

This also introduces a breaking change -- the naming scheme for the database names (SQLite as well) has changed.
This mean that any old runs/database you have for SQLite will now not show up at all since GAB will not recognize these as valid databases (or it will error out).

To solve this use the included tool Compatibility Fix. Currently this will rename your SQLite databases to the new naming scheme automatically.
You'll find it under <your install directory>/tools e.g. localhost:80/gab/tools

to update do:
git pull

or to install the new version to an entirely different dir create a new one and do:
git pull https://github.com/tommiehansen/gab.git

The database name is not required in     Example for mysql: '127.0.0.1:3306,TommieHansenIsTheBest,MySuperPassword' ?
I am getting error:

MySQL db connection test
FAIL Could not connect to MySQL database, error message:
SQLSTATE[HY000] [2002] php_network_getaddresses: getaddrinfo failed: No address associated with hostname

This more have to do with your settings for your database server (and PHP) so you should Google/look into such a problem.

I did but there was no definite solution for  it that I understand. Can I have a single database with all the pairs in it itself?


Try going to /gab/tools and use the Sanity Check to check your system. It was made to check that everything works.
If it does you should get an 'OK' like on this screenshot:

.png   Skärmklipp.PNG (Size: 44.51 KB / Downloads: 10)

Else you'll get errors and you'll have to fix those errors.
  Reply
(11-17-2018, 10:09 AM)tommiehansen Wrote:
(11-16-2018, 09:37 PM)gekko2yuno Wrote:
(11-16-2018, 04:07 PM)tommiehansen Wrote:
(11-16-2018, 02:48 AM)gekko2yuno Wrote:
(04-14-2018, 08:12 PM)gekko2yuno Wrote: The database name is not required in     Example for mysql: '127.0.0.1:3306,TommieHansenIsTheBest,MySuperPassword' ?
I am getting error:

MySQL db connection test
FAIL Could not connect to MySQL database, error message:
SQLSTATE[HY000] [2002] php_network_getaddresses: getaddrinfo failed: No address associated with hostname

This more have to do with your settings for your database server (and PHP) so you should Google/look into such a problem.

I did but there was no definite solution for  it that I understand. Can I have a single database with all the pairs in it itself?


Try going to /gab/tools and use the Sanity Check to check your system. It was made to check that everything works.
If it does you should get an 'OK' like on this screenshot:


Else you'll get errors and you'll have to fix those errors.
This error message is from Sanity check. Huh
If you can give how do you create user and what privileges you grant to user.
  Reply
(11-17-2018, 08:11 PM)gekko2yuno Wrote:
(11-17-2018, 10:09 AM)tommiehansen Wrote:
(11-16-2018, 09:37 PM)gekko2yuno Wrote:
(11-16-2018, 04:07 PM)tommiehansen Wrote:
(11-16-2018, 02:48 AM)gekko2yuno Wrote: I am getting error:

MySQL db connection test
FAIL Could not connect to MySQL database, error message:
SQLSTATE[HY000] [2002] php_network_getaddresses: getaddrinfo failed: No address associated with hostname

This more have to do with your settings for your database server (and PHP) so you should Google/look into such a problem.

I did but there was no definite solution for  it that I understand. Can I have a single database with all the pairs in it itself?


Try going to /gab/tools and use the Sanity Check to check your system. It was made to check that everything works.
If it does you should get an 'OK' like on this screenshot:


Else you'll get errors and you'll have to fix those errors.
This error message is from Sanity check. Huh
If you can give how do you create user and what privileges you grant to user.

Sorry, i simply do not have time to give you server administration support.
Try googling for the error, take it from there. Smile
  Reply
Thanks for the hint tommie! Will downgrade Gekko then Wink
  Reply
hi!
I installed XAMPP with PHP version 7.1+ and wanted to use GA to select parameters, but  i get an error after 120 seconds:
16:00:59 Runner.php ERROR: Running config via curl_post() did not return data.
url: http://localhost:3000/api/backtest | curl status: 0 - No data
I changed the timeout in the file functions.php, but it did not help.
in php.ini installed max_execution_time = 0, but it did not help

environment:
os x: high sierra
Gekko v0.6.7 and Gekko UI v0.2.3.

Prompt, please, in what there can be a problem?
  Reply


Forum Jump:


Users browsing this thread: