Cannot install on Raspberry pi2
Hello All

I tried to install gekko on a Raspberry pi 2 but it doesn't work. I tried to install on a clean RaspBian 

I had the same problem as described here :

pi@raspberrypi:~ $ sudo npm i -g sqlite3 --unsafe-perm

> sqlite3@3.1.13 install /usr/lib/node_modules/sqlite3
> node-pre-gyp install --fallback-to-build

node-pre-gyp ERR! Tried to download(403): https://mapbox-node-binary.s3.amazonaws....arm.tar.gz 
node-pre-gyp ERR! Pre-built binaries not found for sqlite3@3.1.13 and node@8.9.4 (node-v57 ABI) (falling back to source compile with node-gyp) 
make: Entering directory '/usr/lib/node_modules/sqlite3/build'
ACTION deps_sqlite3_gyp_action_before_build_target_unpack_sqlite_dep Release/obj/gen/sqlite-autoconf-3150000/sqlite3.c
TOUCH Release/
CC(target) Release/

Is a step by step tuto exist to install GEKKO on a Raspberry pi 2 ? 

Thanks for all your helps
Same problem on Raspberry Pi 3+B with Raspbian Stretch
On windows 10 no problem!

Please help!
Hello, it works for me on raspberry pi and other platforms with rock64 if I had a little trouble installing it but in the end I managed it and it works. I will leave you some commands that helped me some, but the important thing is that it works without falling.

sudo apt install sqlite
sudo apt install sqlite3
cd gekko
npm install -g node-gyp --build-from-source
npm install sqlite
npm install sqlite3

//for some strategies used are needed and these
npm install talib --unsafe-perm --build-from-source
npm install tulind --unsafe-perm --build-from-source
npm install tulip --unsafe-perm --build-from-source

//if you tell yourself that you do not have permission to install that you can start these commands with sudo

(in case the above does not work)

It is also important to have version 8 of node installed because with 9 the one that installed ocn command
sudo apt install nodejs
does not work it did not work for me

can be eliminated 
which node  //where the node is installed

rm -r /home/pi/.nvm/versions/node    //in this command you have to replace the position that has left the previous command (the position of node files)

install node   
for raspberry pi (first)
depends your cpu this command is only for the raspberry pi first version
to find the correct version you should know that cpu uses your plate and choose the appropriate version on this website 
cat /proc/cpuinfo  //with this command you discover that cpu has your board

this result came to me:

pi@raspberrypi:~ $ cat /proc/cpuinfo

pi@raspberrypi:~ $ cat /proc/cpuinfo
processor       : 0
model name      : ARMv6-compatible processor rev 7 (v6l)
BogoMIPS        : 697.95
Features        : half thumb fastmult vfp edsp java tls
CPU implementer : 0x41
CPU architecture: 7
CPU variant     : 0x0
CPU part        : 0xb76
CPU revision    : 7

Hardware        : BCM2835
Revision        : 000e
Serial          : 0000000048cdee91

you bought what processor you have in my case it's arm6

//you go to the web

//and you choose which node version is for you replace the file name in all the following queries

//raspeberry pi

cd ~
tar -xzf node-v8.9.4-linux-armv6l.tar.gz
node-v8.9.4-linux-armv6l/bin/node -v
cd node-v8.9.4-linux-armv6l/
sudo cp -R * /usr/local/
export PATH=$PATH:/usr/local/bin
node -v
npm -v

cd ~
tar -xf node-v8.9.4-linux-arm64.tar.gz
node-v8.9.4-linux-arm64/bin/node -v
cd node-v8.9.4-linux-arm64/
sudo cp -R * /usr/local/

export PATH=$PATH:/usr/local/bin
node -v
npm -v

//in some cases I have needed and this later but it should no longer be necessary
sudo apt-get install -y build-essential

and then continue with the commands that you leave at the beginning

couple lover operated the gekko you will need after closing ssh

npm install pm2 -g

pm2 start /home/pi/gekko/gekko.js -f --name gekko -x -- --ui

//then start the gekko (but you have to be sure that gekko's position is in the folder as in my case if it is not)

pm2 save  //save config of pm2 for future reboot will start alone

I am quite a beginner in this I only learned linux when I wanted to install gekko in raspberry and all kinds of problems have come out so I made some notes that happen to you I am not a professional but I hope to have helped people who come well
I had the same issues. I followed the tutorial here: from start to finish and finally got it working.

Forum Jump:

Users browsing this thread: