[SHARE] GAB - Gekko Automated Backtests
(04-09-2018, 12:12 AM)timvang Wrote:
(04-08-2018, 12:41 PM)tommiehansen Wrote:
(04-08-2018, 03:15 AM)timvang Wrote: Hi Tommie,

It's a great tool. Thanks for sharing.

I got it successfully installed. However, after I ran a test, I got an exception error shown in the log:

INFO Exhausted all possible combinations -- stopping automatically.

Fatal error:  Uncaught Exception: Unknown primative for `'no'` on line 2. in /var/www/html/gab/system/class.toml.php:176
Stack trace:
#0 /var/www/html/gab/system/class.toml.php(121): Toml\Parser->parseValue(''no'')
#1 /var/www/html/gab/system/class.toml.php(78): Toml\Parser->processLine('buyImmediately ...')
#2 /var/www/html/gab/system/class.toml.php(24): Toml\Parser->parse()
#3 /var/www/html/gab/system/class.gab.php(178): Toml\Parser::fromString('buyImmediately ...')
#4 /var/www/html/gab/system/class.gab.php(67): GAB\core->parse_toml('buyImmediately ...')
#5 /var/www/html/gab/system/runner.php(39): GAB\core->get_strategies()
#6 {main}
 thrown in /var/www/html/gab/system/class.toml.php on line 176

I am using php 7.2.4 and running the test from UI. Do you know what could be the root cause? Thanks!


The root cause may be because of the mixed input that causes the thing to not really know what type of parsing to do.
Basically there are two modes: multi-dimensional array and plain. There should be a line-per-line check for this, but it may not be a 100%
since i haven't had time to really test all variations of everything yet.

Could you try running something that isn't structured in such a way and see if you get the same errors?

Basically something that does not mix [HEADER] with plain type(s) as per your example.

Another thing you can do is run in DEBUG-mode to see if the params changes the way you have set it up to do.
That will also clearly say if it's the POST-function that fucks up or if there is something else.

Thanks Tommie! When I ran in DEBUG mode, I saw the parameters changed according to the configurations. I did not see the error reported in the debug mode, but did not see the test result after the test stopped running.

I got the same error when I ran your RSI BULL/BEAR ADX strategy. I saw the same error even when I did not setup any dynamic parameters for the test

Another question: Does 'Completed" in the log  below show the number of completed test runs with different configurations?

  STATUS Running with 1 threads  COMPLETED 0  DURATION 0h 0m 0s

If I don't set any dynamic parameter for my test, would I expect to see 1 test completed?


Hi timvang,

I have an error the same as you. Do you have fixed it? Please sent me the way if you did it.


Messages In This Thread
RE: [SHARE] GAB - Gekko Automated Backtests - by daibangden - 07-11-2018, 08:40 AM
YT - by mtom78632 - 07-17-2021, 06:02 AM
WW - by mtom78632 - 07-18-2021, 07:12 AM

Forum Jump:

Users browsing this thread: