[SHARE] GAB - Gekko Automated Backtests
#97
(04-17-2018, 03:53 PM)gekko2yuno Wrote: Hi
I am getting error messages. It worked last time but after the pull its not working.I am on nginx with ssl.


Code:
Notice: Trying to get property of non-object in /var/www/gab/system/class.gab.php on line 113

Warning: Invalid argument supplied for foreach() in /var/www/gab/index.php on line 34
CLEAR CACHE
Notice: Undefined variable: dateFrom in /var/www/gab/index.php on line 165

Notice: Undefined variable: dateTo in /var/www/gab/index.php on line 166

This mean that
1. You have no Gekko UI instance running, thus it cannot get datasets since the source returns 0 (null) -- in this case everything fails.
2. You have failed to point your user.config.php to your Gekko server or have pointed it to somewhere that is no longer valid

Do note that in a couple of versions ago it looked like this: $server = "http://localhost:3000/api".
This has changed to "http://localhost:3000".

To solve
1. Check that you actually have Gekko UI running somewhere
2. Check your user.config.php file inside gab/system/user.config.php
3. Check the user.config.sample.php to see if you're missing something obvious
4. Run gab/tools/ and click 'Sanity check' to see if it complains about something
5. If everything fails create a new directory and git clone gab into that new directory and see if it works (you may have edited system files)

Good luck!
  Reply


Messages In This Thread
RE: [SHARE] GAB - Gekko Automated Backtests - by tommiehansen - 04-17-2018, 04:21 PM

Forum Jump:


Users browsing this thread: