problem installing dependencies (solved)
hello all.

I am having trouble installing the other libraries, if anyone can shed any insight into this i would really appreciate it, please bare in mind i know very little about linux.

many thanks

chrx@chrx:~$ npm install tulind

> tulind@0.8.10 install /home/chrx/node_modules/tulind
> node-pre-gyp install --fallback-to-build

node-pre-gyp ERR! Tried to download(404): 
node-pre-gyp ERR! Pre-built binaries not found for tulind@0.8.10 and node@9.10.1 (node-v59 ABI, glibc) (falling back to source compile with node-gyp) 
make: Entering directory '/home/chrx/node_modules/tulind/build'
  CXX(target) Release/
make: g++: Command not found recipe for target 'Release/' failed
make: *** [Release/] Error 127
make: Leaving directory '/home/chrx/node_modules/tulind/build'
gyp ERR! build error 
gyp ERR! stack Error: `make` failed with exit code: 2
gyp ERR! stack     at ChildProcess.onExit (/usr/lib/node_modules/npm/node_modules/node-gyp/lib/build.js:258:23)
gyp ERR! stack     at ChildProcess.emit (events.js:180:13)
gyp ERR! stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:209:12)
gyp ERR! System Linux 4.9.4-galliumos-braswell
gyp ERR! command "/usr/bin/node" "/usr/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "build" "--fallback-to-build" "--module=/home/chrx/node_modules/tulind/lib/binding/Release/node-v59-linux-x64/tulind.node" "--module_name=tulind" "--module_path=/home/chrx/node_modules/tulind/lib/binding/Release/node-v59-linux-x64" "--napi_version=2" "--node_abi_napi=napi"
gyp ERR! cwd /home/chrx/node_modules/tulind
gyp ERR! node -v v9.10.1
gyp ERR! node-gyp -v v3.6.2
gyp ERR! not ok 
node-pre-gyp ERR! build error 
node-pre-gyp ERR! stack Error: Failed to execute '/usr/bin/node /usr/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js build --fallback-to-build --module=/home/chrx/node_modules/tulind/lib/binding/Release/node-v59-linux-x64/tulind.node --module_name=tulind --module_path=/home/chrx/node_modules/tulind/lib/binding/Release/node-v59-linux-x64 --napi_version=2 --node_abi_napi=napi' (1)
node-pre-gyp ERR! stack     at ChildProcess.<anonymous> (/home/chrx/node_modules/node-pre-gyp/lib/util/compile.js:83:29)
node-pre-gyp ERR! stack     at ChildProcess.emit (events.js:180:13)
node-pre-gyp ERR! stack     at maybeClose (internal/child_process.js:936:16)
node-pre-gyp ERR! stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:220:5)
node-pre-gyp ERR! System Linux 4.9.4-galliumos-braswell
node-pre-gyp ERR! command "/usr/bin/node" "/home/chrx/node_modules/.bin/node-pre-gyp" "install" "--fallback-to-build"
node-pre-gyp ERR! cwd /home/chrx/node_modules/tulind
node-pre-gyp ERR! node -v v9.10.1
node-pre-gyp ERR! node-pre-gyp -v v0.9.0
node-pre-gyp ERR! not ok 
Failed to execute '/usr/bin/node /usr/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js build --fallback-to-build --module=/home/chrx/node_modules/tulind/lib/binding/Release/node-v59-linux-x64/tulind.node --module_name=tulind --module_path=/home/chrx/node_modules/tulind/lib/binding/Release/node-v59-linux-x64 --napi_version=2 --node_abi_napi=napi' (1)
npm WARN enoent ENOENT: no such file or directory, open '/home/chrx/package.json'
npm WARN chrx No description
npm WARN chrx No repository field.
npm WARN chrx No README data
npm WARN chrx No license field.

npm ERR! errno 1
npm ERR! tulind@0.8.10 install: `node-pre-gyp install --fallback-to-build`
npm ERR! Exit status 1
npm ERR! 
npm ERR! Failed at the tulind@0.8.10 install script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR!     /home/chrx/.npm/_logs/2018-04-01T09_54_52_097Z-debug.log

Messages In This Thread
problem installing dependencies (solved) - by swamps - 04-01-2018, 10:10 AM
RE: problem installing dependencies - by swamps - 04-01-2018, 10:26 AM
RE: problem installing dependencies - by ankasem - 04-01-2018, 05:32 PM
RE: problem installing dependencies - by swamps - 04-01-2018, 07:22 PM

Forum Jump:

Users browsing this thread: