error " Gekko was unable to set the portfolio"
New to Gekko, did some backtesting and decided to run RSI on my poloniex account.  fired it up and got this.  To make it clean, I restarted Gekko and went straight to the live bot to get everything from start to the error.

I saw on GitHub that the standard suggestion was to delete the API key and get fresh one.  That did not resolve the problem.


   Gekko v0.5.12
    I'm gonna make you rich, Bud Fox.

Serving Gekko UI on http://localhost:3000/

  <-- GET /api/imports
  --> GET /api/imports 200 3ms 2b
  <-- GET /api/gekkos
  --> GET /api/gekkos 200 0ms 2b
  <-- GET /api/gekkos
  --> GET /api/gekkos 200 1ms 2b
  <-- GET /api/apiKeys
  --> GET /api/apiKeys 200 1ms 12b
  <-- GET /api/exchanges
  --> GET /api/exchanges 200 1,287ms 81.12kb
  <-- GET /api/configPart/candleWriter
  --> GET /api/configPart/candleWriter 200 2ms 47b
  <-- GET /api/configPart/performanceAnalyzer
  --> GET /api/configPart/performanceAnalyzer 200 1ms 144b
  <-- GET /api/strategies
  --> GET /api/strategies 200 4ms 2.02kb
  <-- GET /api/configPart/paperTrader
  --> GET /api/configPart/paperTrader 200 1ms 132b
  <-- POST /api/startGekko
Gekko 604006522099786 started
  --> POST /api/startGekko 200 33ms 148b
  <-- POST /api/startGekko
Gekko 376912847127918 started
  --> POST /api/startGekko 200 14ms 373b

Gekko encountered an error and can't continue

Gekko encountered an error and can't continue


Gekko was unable to set the portfolio

Meta debug info:

Gekko version: v0.5.12
Nodejs version: v8.9.4
I see a number of people have viewed this-- but no replies.  Is there some other data I can supply to help figure this out?

I've searched this forum and the GitHub community for solutions but found not threads about this here and the only GitHub solution was to get new API key from Polo, but that didn't solve anything.

I'm using the UI module to trade, but the above was the console readout that runs in the background while you use the UI.  Backtesting worked fine, so I know the JS bot worked when it's local data and not trying to initiate trades online.  Which made me believe the API key might have been the problem.

My Polo API key does not have IP restrictions enabled, nor do I have withdraw enabled.  It is the basic API settings.

insert photo didn't work, here is a link to a screen grab of Polo API settings.  Key redacted.

issue reported on GitHub also:

Forum Jump:

Users browsing this thread: