Gekko Forum
RPI 3B headless install problems - Printable Version

+- Gekko Forum (https://forum.gekko.wizb.it)
+-- Forum: Gekko (https://forum.gekko.wizb.it/forum-13.html)
+--- Forum: Technical Support (https://forum.gekko.wizb.it/forum-19.html)
+--- Thread: RPI 3B headless install problems (/thread-57893.html)



RPI 3B headless install problems - Maupolom - 04-01-2019

Hello there,

On my clean install RPI3 it seems impossible to install gekko without errors.

Install history


Code:
    1  sudo nano /etc/dhcpcd.conf
    2  sudo reboot now
    3  raspi-config
    4  sudo raspi-config
    5  ifconfig
    6  sudo raspi-config
    7  sudo nano /etc/dhcpcd.conf
    8  sudo apt-get update
    9  sudo apt-get upgrade
   10  sudo nano /etc/dhcpcd.conf
   11  sudo shutdown now
   12  ifconfig
   13  node -v
   14  node
   15  sudo apt-get install -y nodejs
   16  npm
   17  node -v
   18  sudo apt install npm
   19  npm -v
   20  sudo apt-get install git-core
   21  sudo apt-get install git
   22  git clone git://github.com/askmike/gekko.git -b stable
   23  cd gekko
   24  npm install --only=production
   25  history

After #24 the error is extensive:

Code:
npm ERR! System Linux 4.14.98-v7+
npm ERR! command "/usr/bin/node" "/usr/bin/npm" "install" "--only=production"
npm ERR! cwd /home/pi/gekko
npm ERR! node -v v8.11.1
npm ERR! npm -v 1.4.21
npm ERR! code E405

The npm log file is extensive and attached.

The problem at first glance after going trough some forums is that the NPM version is to low.
At an earlier stage I updated npm to 11 but then sqlite gave a lot of problems along the same line
---
node-pre-gyp WARN Using request for node-pre-gyp https download 
node-pre-gyp WARN Tried to download(403): https://mapbox-node-binary.s3.amazonaws.com/sqlite3/v4.0.6/node-v57-linux-arm.tar.gz 
node-pre-gyp WARN Pre-built binaries not found for sqlite3@4.0.6 and node@8.11.1 (node-v57 ABI, glibc) (falling back to source compile with node-gyp) 
----

I've also tried to install SQLITE separately (sudo apt-get sqlite3) with no results.

I hope somebody can help.

MauPoLom


RE: RPI 3B headless install problems - Maupolom - 04-01-2019

Here is the terminal log after update NPM to v10


RE: RPI 3B headless install problems - TB-Gekko - 04-14-2019

Hey Maupolom,

i just finished building a Raspberry 3b gekko build using the instructions found here:
https://gekko.wizb.it/docs/installation/installing_gekko_on_raspberry_pi_2_or_3.html

Fresh install of raspbian stretch lite.
Version:
April 2019
Release date:
2019-04-08

No errors for me.