Gekko Forum
Wrong time frame in backtest - Printable Version

+- Gekko Forum (
+-- Forum: Gekko (
+--- Forum: General Discussion (
+--- Thread: Wrong time frame in backtest (/thread-57418.html)

Wrong time frame in backtest - bitbot - 07-22-2018

Hello. I'm a new gekko user. I've performed a couple of backtests but something is wrong with the results' time frame. My database range is 3 months, but somehow the results I get on the graph are always depicted as only 1 day long. I have tried different pairs (all from Poloniex) with different strategies, but all gave me the same error. The attached screenshot illustrates the results. Please note the low volume of trades (37) in the supposedly 3 month period. Any help is deeply appreciated.

RE: Wrong time frame in backtest - faldor - 07-23-2018

Not sure if I understand the problem you are having correct but it looks like each entry/close timeframe is varying and not always 1 day long. For example the buy/close just left of the middle of your screenshot. It seems like your strategy is working as intended and only buys or sells when the strategy says to. A strategy won't be bought into the market for the whole duration of the 3 months or it would just be a simple buy. Hopefully I understood correctly and this helps.

RE: Wrong time frame in backtest - bitbot - 07-23-2018

Thank you, Faldor. I think I did not make myself completely clear in the original post. Indeed, the start and end times are correctly shown in the table, but I was actually referring to the graph. If you look at the X axis, you can note that the unities are in hours, intead of months. In fact, the graph shows a 3-hour time frame, instead of a 3-month one. So, it's even less than a day! I've seen some results from other users and their graphs are really different than mine in respect to the X axis. Hope I expalained the problem properly this time!

RE: Wrong time frame in backtest - askmike - 07-24-2018

I'm testing a fix here:

If you want to try it out, see here: (also see recompiling the frontend)

RE: Wrong time frame in backtest - ankasem - 07-24-2018

/gekko/web/vue$ npm install
npm WARN ajv-keywords@3.2.0 requires a peer of ajv@^6.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.4 (node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.4: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})

up to date in 10.668s
/gekko/web/vue$ npm run build

> gekko-vue-ui@0.2.2 build /home/semba1/enler/gekko/web/vue
> vue-cli-service build

⠋  Building for production...

WARNING  Compiled with 2 warnings                                                                                                              21:44:28


entrypoint size limit: The following entrypoint(s) combined asset size exceeds the recommended limit (244 KiB). This can impact web performance.
 app (313 KiB)


webpack performance recommendations:
You can limit the size of your bundles by using import() or require.ensure to lazy load some parts of your application.
For more info visit

 File                                      Size             Gzipped

 dist/vendor/reconnecting-websocket.min    3.13 kb          1.07 kb
 dist/chunk-vendors.f8e19183.js            226.59 kb        77.97 kb
 dist/vendor/d3.js                         208.71 kb        70.23 kb
 dist/app.ed856330.js                      81.05 kb         19.12 kb
 dist/vendor/moment.js                     59.16 kb         20.42 kb
 dist/vendor/toml.js                       23.86 kb         6.22 kb
 dist/vendor/humanize-duration.js          5.43 kb          1.71 kb
 dist/UIconfig.js                          0.60 kb          0.38 kb
 public/UIconfig.js                        0.60 kb          0.38 kb
 dist/vendor/furtive.min.css               11.39 kb         3.80 kb
 dist/app.e1d9fa4d.css                     5.42 kb          1.66 kb

 Images and other types of assets omitted.

DONE  Build complete. The dist directory is ready to be deployed.
Gekko      6.3
Ubuntu  18.04
cd web/vue
npm install
npm run build

RE: Wrong time frame in backtest - askmike - 07-25-2018

@ankasem looks you compiled it great, if you run `node gekko --ui` after that you should have the fix included Smile

RE: Wrong time frame in backtest - ankasem - 07-27-2018

Wrong time in backtest
Real time         01:50    (gmt+3)
İmport Time     22:50    (  Utc  )
Backtest Time 19:50     (??)  3 hours lost+3 (utc) = 6

RE: Wrong time frame in backtest - ankasem - 07-29-2018

Is this time lost alone?